PowerShell 4.0 Support

Nov 12, 2013 at 6:31 AM
Please add support for PowerShell 4.0 :-)
Feb 7, 2014 at 8:33 PM
Find this line
if($PSVersionTable.PSVersion.Major -eq 3) {
    $psversion = 3
    write-host "You are using PowerShell 3.0."
}
and add this line right above it
if($PSVersionTable.PSVersion.Major -eq 4) {
    $psversion = 3
    write-host "You are using PowerShell 4.0."
}
PowerShell v4.0 can use the same assembly version numbers as PowerShell v3.0 because .net 4.5 is backwards compatible.
Nov 13, 2014 at 9:38 PM
Hello !

Since few day i use Windows 8.1 and powershell 4.0. So i have this problem too. I try to add line in ps2exe.ps1 but after compile, my exe don't work :/

So i modify "callPS2EXE.bat" :
last line = powershell.exe -command "&'.\ps2exe.ps1' %cmd%"
Add -version 2.0 = powershell.exe -version 2.0 -command "&'.\ps2exe.ps1' %cmd%"

I hope this can help.
Coordinator
Nov 14, 2014 at 6:35 AM
Hi all!

I uploaded a modified version for PS 4.0.

Regards
Ingo